kvCORE appearing not to save data
Incident Report for Inside Real Estate
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 25, 2019 - 16:03 MDT
Identified
We've identified an issue where kvCORE is not appearing to save data in a timely matter. We're currently addressing and expect performance to return to normal shortly. We expect all saved data to be maintained and to be accessible shortly.
Posted 4 months ago. Jun 25, 2019 - 16:01 MDT
This incident affected: kvCORE CRM.